Fandom

EVN Wiki

PC Plugin Conversion Tutorial

538pages on
this wiki
Add New Page
Talk11 Share

Escape Velocity Nova is designed in such a way that it can be expanded by means of plug-ins. This article is a tutorial for the conversion and installation of Mac plug-ins into Windows plug-in format for Windows computers. For Mac users, to convert Windows .rez plug-ins into Mac format, simply download David Arthur's Mac Plug-in Convertor.

Quick StepsEdit

The quickest and easiest way to extract plug-in archives on Windows is using the Plug-in Extractor for Windows, which can extract and convert almost any archive type in one go.

  1. Download the Plug-in Extractor for Windows.
  2. Drag and drop the plug-in archive you have downloaded onto the "Extract Plug-ins.exe" program.
  3. Successful extraction should produce one or more Windows plug-in files in the .rez format. If you have any difficulty with this, read the program's Read Me file for help and troubleshooting.
  4. Read the plug-in's Read Me file to find out how to install the plug-in files. If it doesn't say, or there's no read me, place them in the Nova Plug-ins folder.
  5. Enjoy.

If you find a plug-in archive that won't work with the extractor for some reason, or you simply prefer using the old method, read on for full instructions on how to expand archives using the SutffIt program.

IntroductionEdit

The Macintosh operating system allows the use of two "forks" for storing information in files: the data fork and the resource fork. Since the information stored in Nova plug-ins and data files are all resources, plug-in files use the resource fork only. On the Windows operating system there is only one fork, the data fork. This means that if a Mac file with a resource fork is placed on a Windows computer the resource fork will simply be discarded.

When Ambrosia decided to port EV Nova to Windows, Contraband Entertainment (the porting company) was forced to devise a new method of implementing plug-ins. The new format they created was given the file extension .rez (Mac plug-in files usually do not have extensions). Furthermore, utilising the MacBinary resource fork conversion already implemented in archive program StuffIt, they wrote a simple plug-in conversion program. A tutorial for using this converter with StuffIt 7.5 (the current version at the time), could be found in the Documentation folder for PC Nova 1.0.6.

Unfortunately, since the tutorial was written, StuffIt has been through a few major upgrades, making the tutorial less useful. The latest version (at the time of this writing) is StuffIt 2010. StuffIt 2009 fixes a long-standing bug with .hqx files, but is no longer avaible. Conversion can still be confusing at times though, due to the plethora of archive formats available on the Nova Add-on Pages.

Getting StartedEdit

In order to expand all types of plug-ins on Windows, you first need to download and install StuffIt. Note that while there is a simpler "StuffIt Expander" program available it lacks the features necessary to extract plug-ins in a useable format, which is why you must download the full StuffIt. Technically this is a 30-day trial program but it will continue to operate freely after the trial period has expired, albeit with some of the "Deluxe" features disabled. If you are only using the expansion features of the program you do not need to feel compelled to purchase it.

Once you have StuffIt installed you need to change a setting in order to extract plug-ins properly. Open the program and click the Options button in the toolbar (or choose Edit -> Application Options). Select Cross Platform from the list on the left, then set the Resource Fork Output to "Encode the data and resource forks for each file together into MacBinary format".

Stuffopts

It is also recommended that you ensure file extensions are always visible in Windows, so that you may easily be able to identify the types of files you are working with. To do this, open any Windows Explorer window and from the menubar choose Tools -> Folder options... (or Organize -> Folder and search options). Click on the View tab and uncheck the "Hide extensions for known file types" option, as shown in the image below:

Winopts

ExpansionEdit

There are five main archive types you will usually encounter: .sit, .sitx, .hqx, .bin and .zip - an image of what the icons look like may be seen below. Note that some icons may differ depending on your file associations.

Tut1-types

As can be seen from the image, .hqx files and .bin files usually have the same icon - this is one reason why "Hide Extensions of Known File Types" should be turned off. All of the files shown in the image above may be downloaded from the Nova Add-on Pages if you would like to practice the expansion on files which are known to work. Generally, all archives are expanded in the same way but there are some things you need to be aware of and understand about these different types. Once you have determined which file type you have, skip to the appropriate section:

.sit/.sitxEdit

.sit (StuffIt) is a proprietary file archive format originally created by Aladdin Systems (but is now owned by SmithMicro) and up until the release of Mac OS X had become a staple for the Macintosh, much as .zip has become a staple for Windows. Since Mac OS X introduced its built-in .zip utility, .zip has become a major archive type on the Mac as well and, along with Macintosh disk images (.dmg), has all but replaced .sit. That said, the majority of plugins found on the addon pages are still in .sit format. The modern version of .sit is .sitx, which is more capable and efficient than .sit but is extracted in the same way. There is also a variant of .sit called .sea, which stands for Self Extracting Archive - on classic Mac OS, these files can expand themselves without requiring StuffIt to be installed (unlike .sit files). On Windows, however, they need to be extracted using StuffIt in the same way as normal .sit files.

To expand a .sit/.sitx file, simply right-click on the file to bring up the context menu, and select StuffIt -> Extract All Here. This is shown in the image below.

Note: For users of 64-bit versions of Windows, you will need to download and install the StuffIt Shell Extension 64-bit patch in order to make the context menu work.

Tut2-sit1

The result in this case should be a folder containing the files below. Some plugins do not have the files contained in a folder. Most plugins have a readme - usually it is in .txt or .rtf format, but this particular plugin has a .html readme contained in a subfolder.

Tut2-sit3

You will see that each plug-in file is now in the form of a .bin file. Note that though they claim to be StuffIt archives, they are not - they are MacBinary files. Attempting to expand them using StuffIt will not produce a desireable result. Sometimes, however, the StuffIt MacBinary conversion can be a little overzealous, and may render some non-plugin files (such as music files or readmes) as .bin files. For these .bin files, you should use "Extract All Here" again on them in order to retrieve the original files. Also, if you see any files named ".DS_Store.bin" or "Icon_.bin" you may delete them, as these are Mac-only files. The .bin files representing plug-ins may now be converted. Skip to the conversion section below.

Note that if the file is extracted incorrectly (for example, if you did not set the MacBinary option in the StuffIt program) then the result will be the files shown below. Since plug-in information is stored in the resource fork, which cannot exist on Windows, the resulting files have a size of zero bytes.

Tut2-sit2

.hqx/.binEdit

.hqx and .bin are both forms of encoding and are not strictly archive types. Such files are almost always encoded .sit archives and will typically (but not necessarily) end in .sit.hqx or .sit.bin. In the nineties, the old version of the .sit format had to be encoded before it could be uploaded to the internet, otherwise some data would be lost. Today it is no longer required, but there are still plenty of older plug-ins found on the addon pages that use this format.

The two formats are both extracted in the same way but .bin (short for MacBinary) has the added confusion of being exactly the same format as the one we want plug-ins to be extracted as in order to convert them. To tell the difference between a .bin encoded plug-in file and a .bin encoded archive, a simple rule of thumb is this: if you downloaded it from the Addon pages, it's an archive, but if you got it as the output from an archive expansion, it's a file. Another test is to simply expand the file with StuffIt - if the result is a zero-size file and another file starting with ._ then it was a .bin encoded plug-in file, and should not have been expanded. Do not put .bin encoded archives through the plug-in convertor, as they will cause it to crash.

To expand a .hqx or .bin encoded archive, use the same "Extract All Here" option as with .sit above. The only difference is you will need to repeat the process on the resulting .sit archive to complete the expansion. The correct result of expansion is shown below.

Tut3-hqx2

Return to .sit instructions for more info or skip to the conversion section below.

.zipEdit

Just to add confusion, there are three kinds of .zip files. Strictly speaking, there's only one kind, but depending on how the compression was done, the results can be very different, so there are effectively three kinds. All three types are simply expanded using WinZip, WinRar, WinAce, or other Windows archive utility of choice - the image below shows expansion using the WinRar context menu expansion option. The three kinds are as follows: PC .zip archives, Mac .zip archives which have been properly compressed, and Mac .zip archives which have not been properly compressed. All three kinds have the same icon in Windows - which is logical, as strictly speaking they're all the same file format.

Tut5-zip1

The first kind is the PC .zip archive. When extracted using WinZip, the result is one or more PC .rez plugin files - the result of the above expansion may be seen in the image below. Simply skip to the Installation section for instructions on what to do next.

Tut5-zip2

The remaining two kinds are the Mac .zip archives. Much like Windows XP, recent versions of Mac OS X come with a .zip compression utility installed. Due to the resource fork problem, Mac users must pre-encode their plugin files in MacBinary format when archiving as a .zip file. However, the OSX utility does not do this, so if a file is compressed using this utility, it cannot be correctly expanded on the PC.

The only way to find if it can be correctly expanded is to simply do the expansion. For the record, the file on the left has been compressed correctly, while the file on the right has not.

Tut5-zip3

If the file was compressed correctly, something like the following files will result. The .bin files need to be converted. Skip to the conversion section below.

Tut5-zip4

If the file was not compressed correctly, the following files will result. The only course of action is to either contact the plugin creator and ask them to re-compress the file, or to (nicely) ask some willing soul who is on a Mac to do it.


Tut5-zip5

ConversionEdit

To convert .bin files in to .rez plugin files, simply drag-and-drop them on to the plugin convertor found in the Nova folder. As can be seen below, it's called "Convert Plug-ins.exe".

Tut2-sit4

A window similar to the following will flash up reasonably fast, and then vanish, and the converted files will appear in the same directory as the files you were converting.

Tut2-sit5

Once this is done, the original .bin files may be safely deleted. In this case, the results are shown below.

Tut2-sit6

Do not drop readmes, music files, image files, or movies onto the convertor, and if an archive is dragged onto the convertor, it will crash. If it does not already have the correct extension, any music file should manually have a .mp3 extension added to the end (the file should already be in the correct format, but they must have the extension for Nova to recognise them). If you are converting a Mac plug-in, it may contain a file called ".DS_Store". This file should be deleted, and not dragged onto the convertor. Note that several files may be converted at once by dragging all of the files at the same time, but if a folder is dropped onto the convertor, it will not work. Once the conversion is done, continue to the Installation section below.

InstallationEdit

Typically, the readme should contain installation instructions. Most plugins are simply placed in the Nova Plug-ins folder, but some large plugins, especially Total Conversions are designed to replace the Nova Data files. In this case, the existing Nova Files folder should be re-named (say, to "Nova Files Original") and the folder containing the TC files be named "Nova Files". Note that plugin files must be directly within the relevant folders - if they are inside a folder which is itself within the Nova Plug-ins folder, then the game will not recognise them.

Also note that many plugins will conflict with each other - usually they will say in the Readme which plugins are compatible, if any (or which ones are not). Plugins load in the following order: files in the Nova Files folder, in alphabetical order, then files in the Nova Plug-ins folder, in alphabetical order. If two plugins share a resource, then the plugin that loads last will take precedence, and only that resource will appear in the game. If you know what you are doing, you could potentially run the game with plugin clashes, but be warned that results can be unpredictible, especially in the more complicated plugins.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.